It is currently Sat Nov 25, 2017 6:07 am




 Page 4 of 6 [ 86 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next
Author Message
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Thu May 05, 2011 7:44 am 

Joined: Mon Jun 21, 2004 7:53 am
Posts: 325
I've read previously that the MyIDE's had/have problems with signal ringing which was dampened on some previous non-flash models by a 33-ohm resistor.

I have two MyIDE+Flash Carts, and both of these have a pair of resistors next to the 74LS245N. But the values are different. On my older (black) cartridge, these are both Brown-Black-Brown -- 100 Ohms. On the newer (clear) cartridge, these are (top) Orange-Orange-Brown -- 330 Ohms and (bottom) Brown-Green-Red -- 1.5K Ohms. (Note: both carts are 74LS245N IC's)

Are these differences significant, and are either/both on-board for the "signal ringing" issue? Perhaps the top resistor is for the LED?

-Larry


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Thu May 05, 2011 10:02 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1250
Location: netherlands
Hi Larry, Steve will surely drop in later with a reply.

For what I recall is that one resistor is for the LED (100-300 Ohm),
the other (1k-4k) for pulling $3Fx-addressing (secondairy IDE-register) up.

Later,
Sijmen.


Online
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Sun May 08, 2011 7:49 am 

Joined: Wed Mar 04, 2009 7:27 am
Posts: 98
Location: United Kingdom
Just tried this mod, and at first the computer insisted on booting straight to the self-test with a corrupted character set. I disconnected one end of the cap, and the computer booted but installing the SDX MyIDE driver produced the usual "No HDD found" message.

Increasingly frustrated...



_________________
The Last Word, MA65 Assembler, RIF SpartaDOS Utilities, XEDIT
Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Sun May 08, 2011 11:52 am 
ERROR AT LINE 0
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1035
Location: Cleveland, Ohio
Video/character set corruption is bus contention. Are you using a non-polarized 220pf capacitor?

You're results are so wildly different from mine I'd really like to see the cart you've been working with. Being able to see if there is a difference between the cart your trying to test with and the ones I'm testing with would be helpful.

Steve


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Sun May 08, 2011 1:10 pm 
ERROR AT LINE 0
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1035
Location: Cleveland, Ohio
Another suggestion would be a lower value capacitor, like 100pf. You could also add a 1k or 2.2k resistor between the CCTRL connection and pin 11 (with the capacitor still directly connected between 10 and 11).

The capacitor connected directly to CCTRL may be making the /E signal to the 245 stay asserted too long, which would explain the bus contention.

Using the RC pair is likely to fix that problem, but an optimal value for those two components would still need to be found. 100pf/2.2k worked for me, but not as well on the 1200XL. 220pf directly connected to CCTRL worked best.

Steve


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Sun May 08, 2011 1:13 pm 

Joined: Wed Mar 04, 2009 7:27 am
Posts: 98
Location: United Kingdom
Here's the cap (non-polarized):

Attachment:
cap.jpg


If it's the wrong type, my mistake.

Here's the cart:

Attachment:
Tucker_cart.jpg


I'd socketed LS245 some time ago (again, when experimenting with ways to get it working by trying HC versions, etc), so the architectural soldering is a sight trickier: I have to source 5v, ground, etc - hence the floating 573. Note - the apparent shorts are only due to the fact I've lifted the chip for the purposes of the photo. Shorts are the first thing I checked.


There are images and/or files attached to this posting. You must be logged-in to view or download this content.



_________________
The Last Word, MA65 Assembler, RIF SpartaDOS Utilities, XEDIT
Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Sun May 08, 2011 1:20 pm 
ERROR AT LINE 0
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1035
Location: Cleveland, Ohio
I hate capacitor markings, but, I think thats 220nf not 220pf.

The picture looks like a 74HC573? 74HC is not strictly TTL compatible. The HC IC will never see a signal as 'low' unless the Atari manages to drive it below 0.8V-0.5V and keep below that level.

How about I send you a set of the same components I'm using and you can try those? Even if it doesn't work, it will remove some uncertainty from the process.

Steve


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Sun May 08, 2011 1:25 pm 

Joined: Wed Mar 04, 2009 7:27 am
Posts: 98
Location: United Kingdom
Ah, sorry - I had a feeling I'd make a mistake with the cap - I'm fairly clueless about the markings.

As for 74HC - 2 of those are all I could pick up at a reasonable price. I wasn't going to spend another 5GBP on a single IC for this thing. I guess I'll have to shelve the testing for the moment, then.



_________________
The Last Word, MA65 Assembler, RIF SpartaDOS Utilities, XEDIT
Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Thu May 12, 2011 9:25 pm 

Joined: Mon Jun 21, 2004 7:53 am
Posts: 325
Steve-

You recommended a 74LS573 and you used a 74HCT573. I see that Jameco shows they have the 74LS573 for $2.19 (although they may have a minimum $ order). Still recommend the LS?

Also, I'd still appreciate your comment about the resistor on the flash cart, please.

Thanks,
Larry


classics wrote:
I hate capacitor markings, but, I think thats 220nf not 220pf.

The picture looks like a 74HC573? 74HC is not strictly TTL compatible. The HC IC will never see a signal as 'low' unless the Atari manages to drive it below 0.8V-0.5V and keep below that level.

How about I send you a set of the same components I'm using and you can try those? Even if it doesn't work, it will remove some uncertainty from the process.

Steve


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Fri May 13, 2011 1:59 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1250
Location: netherlands
I'm going to try this this weekend.
I have a SN74ALS573BN (TI) and a 181 (180pf)
I also have a 331 (330pF) and a 22pf cap to do some variations if needed.

Sóóóóóó curious.... :-)

Later,
Sijmen.


Online
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Fri May 13, 2011 4:14 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1250
Location: netherlands
Brilliant :-)

Did the mod with the 181pF.
(see picture)
Choose my worst stock 800xl that -almost- never boots from myide.

Plugged in the cartridge and booted straigh away.
-big thumbs up-

Flashed to the 4.6beta and did rwtest and crctest.
Not one 'H' error (!)

Later,
Sijmen.


There are images and/or files attached to this posting. You must be logged-in to view or download this content.


Online
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Fri May 13, 2011 11:53 am 
ERROR AT LINE 0
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1035
Location: Cleveland, Ohio
thewhiz wrote:
Steve-

You recommended a 74LS573 and you used a 74HCT573. I see that Jameco shows they have the 74LS573 for $2.19 (although they may have a minimum $ order). Still recommend the LS?

Also, I'd still appreciate your comment about the resistor on the flash cart, please.

Thanks,
Larry


I believe the LS should work as well. I initially recommended it because Sijmen had so much better luck with LS series parts for the 245. In this case it may not matter though.

The resistors are a current limiting resistor for the LED and a pull-up for an unused input. The values used vary and shouldn't effect anything other than the overall LED brightness. If the LED is too bright increasing the LED resistor will help.

Unless you're ordering a bunch of other stuff don't go through all that, I have lots of these parts, I can just send you a few. It will cost less than $1.50 in postage total.

Steve


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Fri May 13, 2011 2:11 pm 
User avatar

Joined: Tue Nov 18, 2003 11:27 pm
Posts: 60
Location: Boot Factory BBS
Steve,
Do you think you will build any MyIDE+Flash carts with the 'fixes' in them anytime? I would be interested in one.

Cabell



_________________
--- bf2k+
WEB: http://bf.amfband.com - BBS: telnet://bfbbs.no-ip.com
Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Fri May 13, 2011 2:15 pm 
ERROR AT LINE 0
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1035
Location: Cleveland, Ohio
bf2k+ wrote:
Steve,
Do you think you will build any MyIDE+Flash carts with the 'fixes' in them anytime? I would be interested in one.

Cabell


I have a handful of them already modified.

If you want one just drop me an e-mail after placing an order and I will send you the modified cart instead.

Steve


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Fri May 13, 2011 2:17 pm 
ERROR AT LINE 0
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1035
Location: Cleveland, Ohio
mr-atari wrote:
Brilliant :-)

Did the mod with the 181pF.
(see picture)
Choose my worst stock 800xl that -almost- never boots from myide.

Plugged in the cartridge and booted straigh away.
-big thumbs up-

Flashed to the 4.6beta and did rwtest and crctest.
Not one 'H' error (!)

Later,
Sijmen.


Very encouraging results! What IDE devices did you try?

Steve


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 4 of 6 [ 86 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: