Atarimax Product Discussion Forums
http://www.atarimax.com/flashcart/forum/

Using the MyIDE+Flash with the 32-in-1 OS upgrade
http://www.atarimax.com/flashcart/forum/viewtopic.php?f=7&t=1520
Page 1 of 2

Author:  gozar [ Tue Feb 18, 2014 11:05 am ]
Post subject:  Using the MyIDE+Flash with the 32-in-1 OS upgrade

Right now I use the OS-35f-OSS-PicoDos image on my MyIDE+Flash. This works well, except for the fact that I can't get Turbobasic XL to run. I have my 32-in-1 installed, but I don't know how to set it to use the internal OS instead of loading it from the cart. How do I do this?

Author:  mr-atari [ Wed Feb 19, 2014 2:55 am ]
Post subject:  Re: Using the MyIDE+Flash with the 32-in-1 OS upgrade

Oh man, 2007? 7 years of flashback :)

Hold OPTION during booting of the cartridge, this seems to bypass the 3.5F MyIDE-OS from loading.
So you have to select the 4.3e OS from the 32-in-1 before.
Not sure anymore about that, hold SELECT?

Author:  gozar [ Wed Feb 19, 2014 10:17 pm ]
Post subject:  Re: Using the MyIDE+Flash with the 32-in-1 OS upgrade

That's what I did, and it seems to work (well, except for the fact that the internal OS is 3.1 :-). Turbobasic XL loads to a black screen though. I can hear key clicks, but nothing happens. Type DOS blind and hitting return doesn't return me to dos either. So it's something with TBXL...

Author:  mr-atari [ Thu Feb 20, 2014 2:02 am ]
Post subject:  Re: Using the MyIDE+Flash with the 32-in-1 OS upgrade

Let me have a look at it, yesterday I tried it quickly with the new 4.8.B3-bios that is in my current machine.
That seems to work, I get a blue screen with TBXL message.
Need to burn a 3.1e and test that.
More news tomorrow.

Author:  mr-atari [ Fri Feb 21, 2014 2:24 am ]
Post subject:  Re: Using the MyIDE+Flash with the 32-in-1 OS upgrade

Ok, I burned a 16k eprom with the MyIDE-3.1e OS.
And plugged that into my 800XL.
Flashed a 1mb+IDE with the 2007_OSS_Special file.
Booted the system with OPTION down, to disable the 3.5F-OS from booting.
The cartridge menu came up.
Selected BASIC XL and works like a charm.

I have no clue what you are doing wrong.

Perhaps a system that does not like ATARIMAX cartridges?

Later,
Sijmen.

Author:  Sysop*Marius [ Fri Feb 21, 2014 2:28 pm ]
Post subject:  Re: Using the MyIDE+Flash with the 32-in-1 OS upgrade

He asks for TurboBasic XL, which is not Basic XL…

If I read his post, I think he indeed tries to select Basic XL… it's not clear.

Author:  mr-atari [ Sat Feb 22, 2014 2:18 am ]
Post subject:  Re: Using the MyIDE+Flash with the 32-in-1 OS upgrade

Hmmm, thanks, did not catch that.

Gozar:
Please upload or give a link to the OS-35f-OSS-PicoDos you are using.

Turbobasic XL does not work with 3.5F, you need to select the 3.1e from the 32-in-1.

Author:  gozar [ Mon Feb 24, 2014 10:19 pm ]
Post subject:  Re: Using the MyIDE+Flash with the 32-in-1 OS upgrade

mr-atari wrote:
Hmmm, thanks, did not catch that.

Gozar:
Please upload or give a link to the OS-35f-OSS-PicoDos you are using.

Turbobasix XL does not work with 3.5F, you need to select the 3.1e from the 32-in-1.


I'm using the OSS- 2007 image that's floating around in the forums... Here it is:http://www.atarimax.com/flashcart/forum/viewtopic.php?f=7&t=610&hilit=oss The image works great with Action!.

When I boot up off of the internal 3.1e, TBXL loads, but the screen goes black. I can still hear key clicks though. Nothing I type seems to have any effect.

Author:  gozar [ Mon Feb 24, 2014 10:21 pm ]
Post subject:  Re: Using the MyIDE+Flash with the 32-in-1 OS upgrade

Oh wait, it says 2008 OSS Special in the menu. I can't find the image in the forums right now though.

Author:  mr-atari [ Tue Feb 25, 2014 5:01 am ]
Post subject:  Re: Using the MyIDE+Flash with the 32-in-1 OS upgrade

I have no "2008 OSS Special" on file here.
Perhaps I send you this a long time ago as beta?

Can you dump the cartridge and send me the 128k image?
I will have a look at it.

You write TBXL, not BASIC XL, sure you mean TurboBasicXL?

Thanks.

Author:  Sysop*Marius [ Tue Feb 25, 2014 7:55 am ]
Post subject:  Re: Using the MyIDE+Flash with the 32-in-1 OS upgrade

What is the DOS you have on D1: on your MyIDE disk.

Perhaps this DOS does not cooperate with the Basic you want to run?

And indeed: are you talking about OSS BASIC XL (the one on the cart in the flash menu) or Turbo Basic XL 1.5?

Author:  gozar [ Tue Feb 25, 2014 3:32 pm ]
Post subject:  Re: Using the MyIDE+Flash with the 32-in-1 OS upgrade

Ok, here's the image on the cart: viewtopic.php?f=7&t=691&hilit=action

And I'm trying to use Turbobasic XL 1.5. I boot up holding down the Option key to bypass the cart and boot from my internal 3.1e rom. MyDos loads.

I then load TBXL, which it seems to do, except I end up with a blank screen. I can hear key clicks when I type on the keyboard though.

Author:  mr-atari [ Wed Feb 26, 2014 2:46 am ]
Post subject:  Re: Using the MyIDE+Flash with the 32-in-1 OS upgrade

Guess you have to consult the guy ho made this image.

I have no idea what he has hacked into the original image that I made.

But it seems that there is a 8k flash-bank still active.
So OPTION only bypasses the cartridge from booting, not disabling it.

Author:  gozar [ Thu Feb 27, 2014 12:32 pm ]
Post subject:  Re: Using the MyIDE+Flash with the 32-in-1 OS upgrade

More info:

Flashed the 3.5F image (of course, I can't find the forum post now, the zip was MYIDE35f-FLASHER.zip ) and had the same issues as using the 2008 OSS image.

I then flashed it with the 2007 OSS Special (viewtopic.php?f=7&t=610) and Turbobasic XL worked! The Last Word didn't want to load, but that's probably something else I messed up. :-) An odd thing about this image, holding down the option on start up always gives me the flashcart menu. Selecting 0 and holding down the option seems to use my internal MyIDE ROM instead of the cart since Turbobasic XL runs.

I'm going to stick with the 2007 OSS Flash for now. My internal MyIDE version is 3.1e.

Author:  mr-atari [ Fri Feb 28, 2014 2:28 am ]
Post subject:  Re: Using the MyIDE+Flash with the 32-in-1 OS upgrade

I made the boot-sequence (2007 OSS special) like this:
-first detect OPTION, if pressed, do not load 3.5F from flash (but use the OS in the atari, this can be 3.1e / 32-in-1).
-then run the cartridge-menu.

Thanks for the feedback.

Page 1 of 2 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/