It is currently Fri Aug 23, 2019 9:18 am




 Page 1 of 1 [ 4 posts ] 
Author Message
 Post subject: Image Menu won't write to disks (reads from them fine)
PostPosted: Thu Jul 25, 2013 8:17 pm 

Joined: Thu Jun 27, 2013 4:36 pm
Posts: 1
Greetings!
I have an Atari 130XE PAL with the AtariMax MyIDE-II cartridge. I've transferred over a bunch of images to the Image Menu using the myidetool.exe on my PC.
I can run them successfully on the Atari but I can't write them out to disk using the "<" option. The screen does a quick flicker and then refreshes the image list.
The option to read floppies to the Image Menu works fine ">". I tried this with a Percom Data floppy drive and an Atari 1050 floppy drive (same result).

MyBIOS 20130105
FAT32 Loader 20130224
Atari 1050 floppy drive
Percom Data floppy drive

Thanks,
Randy


Offline
 Profile  
 
 Post subject: Re: Image Menu won't write to disks (reads from them fine)
PostPosted: Fri Jul 26, 2013 12:37 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1363
Location: netherlands
Hi Randy,

That is one of the bugs still on the to-do list.
Sorry about that.

Grtz,
Sijmen.


Offline
 Profile  
 
 Post subject: Re: Image Menu won't write to disks (reads from them fine)
PostPosted: Fri Aug 02, 2013 11:55 pm 

Joined: Fri Aug 02, 2013 11:51 pm
Posts: 1
The X: device is interesting... do you think it would work from BASIC using CIO commands or would it require some assembly to use the SIO vector?



_________________
http://www.pass-4sure.me.uk/dumps/PK0-003.html
http://www.comptia.org/
http://www.ucla.edu/
http://en.wikipedia.org/wiki/Campbellsville_University
Offline
 Profile  
 
 Post subject: Re: Image Menu won't write to disks (reads from them fine)
PostPosted: Sat Aug 03, 2013 1:02 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1363
Location: netherlands
Yes, the X: device should be fully functional.
Program-specifications are in the manual.
You can call it with SIO, not CIO.

Please be sure to have the latest MyBIOS on your cartridge.
The early releases have some errors in these routines.
viewtopic.php?p=7181#p7181

Grtz,
Sijmen.


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 4 posts ] 


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron