It is currently Mon Dec 18, 2017 11:41 am




 Page 1 of 4 [ 53 posts ]  Go to page 1, 2, 3, 4  Next
Author Message
 Post subject: The Dark Crystal & Ulysses And The Golden Fleece
PostPosted: Sun Feb 26, 2017 5:53 pm 

Joined: Sat Feb 25, 2017 2:34 pm
Posts: 52
Can someone tell me how to run these with the MyIDE-II? The FAT32 Loader launches Disk 1 of The Dark Crystal but when it asks for the next Disk, I don't know what to do. The Loader won't run Ulysses at all.

I read that you can use an "image" method but I can't find instructions how to do that. Thanks.


Offline
 Profile  
 
 Post subject: Re: The Dark Crystal & Ulysses And The Golden Fleece
PostPosted: Mon Feb 27, 2017 3:27 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1258
Location: netherlands
Can you zip and upload the ATR-images?

I can test and see if they run from image-mode using MyBIOS.

Some questions:
-Did you update the cartridge to 4.9?
-Did you INIT the CF-card using the MyIDE-MENU?

Grtz,
Sijmen.


Offline
 Profile  
 
 Post subject: Re: The Dark Crystal & Ulysses And The Golden Fleece
PostPosted: Mon Feb 27, 2017 7:40 pm 

Joined: Sat Feb 25, 2017 2:34 pm
Posts: 52
Hello. I have MyBIOS 4.8-B3 and I used my PC to format the card. I followed this guide to get set up...

https://www.youtube.com/watch?v=YQodgRABCUA

The .zip is attached.

Thanks!


There are images and/or files attached to this posting. You must be logged-in to view or download this content.


Offline
 Profile  
 
 Post subject: Re: The Dark Crystal & Ulysses And The Golden Fleece
PostPosted: Tue Feb 28, 2017 4:28 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1258
Location: netherlands
Ok, MyBIOS 4.8.B3, long time ago I have seen that version coming to the surface.

I tested 4.8.6 4.8.B3 and 4.9.B16
Both work on 4.9.B16.

When you are not used to MyBIOS, it can be hard to understand how to use it.

FIRST:
Best is to upgrade to 4.9.B16
download/file.php?id=1697
Download/unzip and put MyIDE-][.BIN in your fat32 partition.
Boot the Atari, select the fat-loader, select MyIDE-][.BIN and press CNTRL-F
This will flash and update your cartridge and content.

REMEMBER:
Main-Menu in 4.9 is now holding HELP down > 1 sec.
For compatibility reasons all MyBIOS-hotkeys are now time-delayed and beep (user feedback) when accepted.

SECOND:
Put your CF card in the PC.
Use "MyIDE Drive Manager LBA2".
Your image-space should appear if your CF-card is partitioned with MyIDE (if not, reply and I help you out).
Copy the ATR in sequence to the CF-card, using the DISK (write ATR image) icon.
Check if the images are indeed in sequence....
Exit the manager.

LOADING:
Boot the Atari, select MyBIOS 4.9.B16, press/hold HELP.
Now you are in the main menu.
press START.
Now you are in the image menu.
Select the first disk of the set, press enter/fire, this will mount this disk as D1:
Press C to coldstart and boot.

Changing disks:
Press/hold SHIFT+CONTROL+[number] until the beep.


Offline
 Profile  
 
 Post subject: Re: The Dark Crystal & Ulysses And The Golden Fleece
PostPosted: Tue Feb 28, 2017 4:35 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1258
Location: netherlands
Addition:
If you want to save your game, better include a extra disk in the sequence.
I always add a empty formatted disk at the end of the line.
Default is that images are write protected.

Assume you have a 6 disk game and 7 is the empty disk.

So when you want to save and the game asks you to:
First do this:
SHIFT+SHIFT+7 (beep) -> set disk 7 in D1:
SHIFT+CONTROL+P (beep) toggle R/W <-> Read only
Follow the instructions on the screen.
Then to continue.
SHIFT+CONTROL+[number] (beep), most likely the game asks for the correct disk.
SHIFT+CONTROL+P (beep), to set the image to read only, just to be sure nothing happens now.....

If you can't remember all those hotkeys, you can try HELP.
Press 7, Press P, ESC.
If the game is compatible to be interrupted by others.....

Grtz,
Sijmen.


Offline
 Profile  
 
 Post subject: Re: The Dark Crystal & Ulysses And The Golden Fleece
PostPosted: Tue Feb 28, 2017 9:21 am 

Joined: Sat Feb 25, 2017 2:34 pm
Posts: 52
Hello. I updated MyBIOS to 4.9.B16. I put the CF in my PC but I can't find "MyIDE Drive Manager LBA2". My CF was partitioned with my PC.


Offline
 Profile  
 
 Post subject: Re: The Dark Crystal & Ulysses And The Golden Fleece
PostPosted: Tue Feb 28, 2017 12:48 pm 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1258
Location: netherlands
viewtopic.php?f=17&t=1592

On newer windows, run as administrator to have full access.


Offline
 Profile  
 
 Post subject: Re: The Dark Crystal & Ulysses And The Golden Fleece
PostPosted: Tue Feb 28, 2017 11:21 pm 

Joined: Sat Feb 25, 2017 2:34 pm
Posts: 52
Hi. I downloaded the tool but I cannot get it to run...even running as administrator. I have Windows 10. I just get a blank interface and a Failed to initialize error.


There are images and/or files attached to this posting. You must be logged-in to view or download this content.


Offline
 Profile  
 
 Post subject: Re: The Dark Crystal & Ulysses And The Golden Fleece
PostPosted: Wed Mar 01, 2017 2:58 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1258
Location: netherlands
I have no idea about windows, I'm an 8-bit guy.

But I'm on windows 10 too, that works for me.
Before that XP and 7, all worked fine.
O O O Microsoft...... :-(

Screenshot my test CF-card.

Screenshot my settings (right) and what I get (left).
First insert the CF-card, then start the manager.

So I have it unzipped here:
"D:\atari myide manager LBA2"
Startup folder:
"D:\atari myide manager LBA2\Release"
Target:
"D:\atari myide manager LBA2\Release\MyIDEDriveManager.exe"

Does windows 10 still have a command-box?
Then you can use it from the command-line, old fashion style.
I haven't used this for a decade, so I have to investigate first.


There are images and/or files attached to this posting. You must be logged-in to view or download this content.


Offline
 Profile  
 
 Post subject: Re: The Dark Crystal & Ulysses And The Golden Fleece
PostPosted: Wed Mar 01, 2017 5:08 pm 

Joined: Sat Feb 25, 2017 2:34 pm
Posts: 52
I used to be an Atari guy but that was so long ago. I forgot the Atari and I only know the PC now but I want to learn it again. Thanks for the screen grabs but it still doesn't work. Do you know the email address of the guy who wrote the Drive Manager? Windows 10 does have a Command Prompt so I may be stuck using that.

I found some docs on using the command-line myidetool and here's what I did.


1) Listed the disks on my system. PhysicalDrive1 was the CF so that's what I want...not PhysicalDrive0 which is my C: Drive.

C:\MyIDE Drive Manager\Tools>myidetool --list

MyIDE Tool V0.46-FAT
\\.\PhysicalDrive0: 121601/255/63 C/H/S, 953867MB
\\.\PhysicalDrive1: 243/255/63 C/H/S, 1906MB
\\.\PhysicalDrive2: reading drive geometry failed
\\.\PhysicalDrive3: reading drive geometry failed
\\.\PhysicalDrive4: reading drive geometry failed


2) Listed the partition table to see what I currently have.

C:\MyIDE Drive Manager\Tools>myidetool \\.\PhysicalDrive1 -l -L

MyIDE Tool V0.46-FAT
MyIDE 3.x/4.x CHS partition table:
3884 cylinders 16 heads 63 sectors (1008 sectors per cyl)
Image space: first cylinder: 2048 cylinders per slot: 2 total slots: 918
partitions: 1 max: 15
option byte: 00100000 drive bits: 00000001
part active drv start end dns sectors name
1 yes D1: 1792 1858 DD 65535 MYDOS
2 no --- 0 0 SD 0
3 no --- 0 0 SD 0
4 no --- 0 0 SD 0
5 no --- 0 0 SD 0
6 no --- 0 0 SD 0
7 no --- 0 0 SD 0
8 no --- 0 0 SD 0
9 no --- 0 0 SD 0
10 no --- 0 0 SD 0
11 no --- 0 0 SD 0
12 no --- 0 0 SD 0
13 no --- 0 0 SD 0
14 no --- 0 0 SD 0
15 no --- 0 0 SD 0

Image slot information:
slot# dn name
162: DD kNm-90yah'dC%1H<AbQ^o
195: DD "ft;xs79]t8VMH)fsi.7GM
230: ED =13YbJWb?xyt0RI!(8(CsE
284: DD ha;G qS@A(%| '1!
422: ED !w4D?At^Qdq>8XFV'xpMf<
443: SD %n"W*DPE$V5jZS!0B<
478: DD qRSb5=*hgeOfu3-HoB
730: DD )UP&h@8JnepLo4pG^
746: ED U;hdr@/H>wXHM.=BP4Y!mex
885: DD VqfzNpv,[NH-EE-|s+^


3) Added the 3 Ulysses .atr files one at a time. I copied the 3 .atr files to the same directory I am running the tool in. After each command I would get a progress message.

C:\MyIDE Drive Manager\Tools>myidetool \\.\PhysicalDrive1 -i 1 -w "Ulysses And The Golden Fleece [Side A].atr" -L
C:\MyIDE Drive Manager\Tools>myidetool \\.\PhysicalDrive1 -i 2 -w "Ulysses And The Golden Fleece [Side B].atr" -L
C:\MyIDE Drive Manager\Tools>myidetool \\.\PhysicalDrive1 -i 3 -w "Ulysses And The Golden Fleece [Side C].atr" -L

4) An image slot listing after this was done showed...

Image slot information:
slot# dn name
1: SD Ulysses And The Golden Fleece
2: SD Ulysses And The Golden Fleece
3: SD Ulysses And The Golden Fleece
162: DD kNm-90yah'dC%1H<AbQ^o
195: DD "ft;xs79]t8VMH)fsi.7GM
230: ED =13YbJWb?xyt0RI!(8(CsE
284: DD ha;G qS@A(%| '1!
422: ED !w4D?At^Qdq>8XFV'xpMf<
443: SD %n"W*DPE$V5jZS!0B<
478: DD qRSb5=*hgeOfu3-HoB
730: DD )UP&h@8JnepLo4pG^
746: ED U;hdr@/H>wXHM.=BP4Y!mex
885: DD VqfzNpv,[NH-EE-|s+^


I then booted the Atari with the CF card and selected MyBIOS and then the Image Manager. The 1st 3 slots showed "Ulysses" and I selected the 1st one. Back in the MyBIOS Main Menu it showed it was selected as the Image. I pressed C for a cold powerUp but the system just booted into MyDOS.

I did something wrong but I'm not sure what.


Offline
 Profile  
 
 Post subject: Re: The Dark Crystal & Ulysses And The Golden Fleece
PostPosted: Thu Mar 02, 2017 3:05 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1258
Location: netherlands
You did a great job working with the command line.
Well done.

I found yesterday the same, opening cmd.exe as administrator.
Made a short-cut to my desktop in case I need that in future.

The windows overlay should take care of all that.
No Idea why it won't start at your place.

OK, you are in theory ready to go, all is set correctly.
The only reason why it perhaps boot to MyDOS [from logical]
instead of the game [from image] is a possible Image-flag bug....

Use HELP twice [MyIDE menu] and toggle M off (normal video), ESC, S(ave).
RHI should be highlighter, PM off (default values for MyIDE).

Now boot again, HELP, START, select image, enter, C.

This is the last screen before you press C, all set correctly.
Note iMag and Prot are now on, since you used the image-menu to select a disk.
This should work......

You have a stock Atari OS (like rev-2) running, right?


There are images and/or files attached to this posting. You must be logged-in to view or download this content.


Offline
 Profile  
 
 Post subject: Re: The Dark Crystal & Ulysses And The Golden Fleece
PostPosted: Thu Mar 02, 2017 5:37 pm 

Joined: Sat Feb 25, 2017 2:34 pm
Posts: 52
My "M" was already off. However, my menu is different than yours. My OS is rev 2. Also, the background color on mine is not that nice brownish color that yours is.


There are images and/or files attached to this posting. You must be logged-in to view or download this content.


Offline
 Profile  
 
 Post subject: Re: The Dark Crystal & Ulysses And The Golden Fleece
PostPosted: Fri Mar 03, 2017 2:47 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1258
Location: netherlands
Menu is the same, but because I have other needs; the partitions are different and the card has other size.

You seem to have the standard pre-installed partitions when you buy from Atarimax.

The color should be golden/yellow, if not, you need to trim the color-adjust.
Found on the bottom of your Atari, seen from the keyboard-side, bottom left.
Small flat head screwdriver. Known issue due to aging, mostly on NTSC, I have PAL.
Just a very small twist to left or right.
But most users leave the color as it is.

OK, just to be sure, in the MyIDE menu:
Do nothing, only ESC&save (yes).

Now reboot, load the BIOS, hold HELP, START, select first disk, ENTER.
Back in the MAIN MENU, is the screen the same as mine?
So all "ON" including the inverse > ?
Then press C, must start this image....


Offline
 Profile  
 
 Post subject: Re: The Dark Crystal & Ulysses And The Golden Fleece
PostPosted: Fri Mar 03, 2017 5:59 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1258
Location: netherlands
https://www.youtube.com/watch?v=LoMP3XA ... e=youtu.be

I press:
RETURN
HELP
HELP
ESC
Y
START
[select image]
ENTER
[check my screen]
C
[atari is booting]
SHIFT+CONTROL+2 (beep)
START

Ignore the difference in Cartridge content and MyIDE-partitions.
I use 4.9.B16 and your files.

Hope this brings some light.


Offline
 Profile  
 
 Post subject: Re: The Dark Crystal & Ulysses And The Golden Fleece
PostPosted: Fri Mar 03, 2017 9:31 pm 

Joined: Sat Feb 25, 2017 2:34 pm
Posts: 52
Thanks for the video. If I follow your steps...toggling M on and off again and saving, after selecting the image "Ulysses" and then pressing C, I don't go to MyDOS, I just go to a black screen. If I do the same thing with "Dark Crystal", it works! I read that "Ulysses" requires OS-B. Are you using OS-B to get it to work?


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 4 [ 53 posts ]  Go to page 1, 2, 3, 4  Next


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron