Atarimax Product Discussion Forums
https://www.atarimax.com/flashcart/forum/

MyIDE-ONLY, the alternative way to support MyIDE-partitions.
https://www.atarimax.com/flashcart/forum/viewtopic.php?f=17&t=2104
Page 1 of 1

Author:  mr-atari [ Thu Sep 07, 2017 2:14 am ]
Post subject:  MyIDE-ONLY, the alternative way to support MyIDE-partitions.

On my homepage, you find this.
Please consult the read-me/txt files.

My main goal was to support MyIDE-partitions without an OS that occupies 16k RAM or the need of modding your Atari with a custom OS.

Supported:
SHIFT+CONTROL hotkeys: RIPM, numbers, ESC (reset), TAB (restart), CAPS (reboot)
MyIDE-images and -partitions

It is a completely different way to catch IO and patch this to CF-access.
The main core runs from MyIDE-][-SRAM, thus has almost zero footprint of Atari-RAM usage.
Therefore Turbo_BASIC and other games/programs (like RED MAX) will load/run fine.
-yeay-

Compatibility is relative high and runs on any Atari 400/800 or XL/XE with stock ATARI-OS.
During boot-up, you can use the MyIDE-MENU to manage your partitions or IMAGE-MENU to select an image.
When you have updated the MyIDE-][ content, you can also select languages at slots 13,14 or 15

http://www.mr-atari.com/Mr.Atari/MyIDE-ONLY/

Author:  darwinmac [ Sun Jan 14, 2018 3:49 pm ]
Post subject:  Re: MyIDE-ONLY, the alternative way to support MyIDE-partiti

Thank you so much for doing this. It allows me to run Turbo Basic XL or compiled TBXL programs while still not modifying my Atari with MyBIOS in ROM.

Bob C

Author:  mr-atari [ Fri Feb 02, 2018 4:36 am ]
Post subject:  Re: MyIDE-ONLY, the alternative way to support MyIDE-partiti

Version #6 now online.

#6
Fixed, 1200XL rev.11 bootup failure.
Changed, upgraded ATBasic to 1.55

Author:  mr-atari [ Sat Feb 03, 2018 6:25 am ]
Post subject:  Re: MyIDE-ONLY, the alternative way to support MyIDE-partiti

How about this update:
It was a lot of work, but I'm happy with the result.
:-D

#7
Added, 600XL (16k) support.
Added, 400/800 (8k modules, upto 48k) support.
Added, 1200XL rev.10 support.
Added, 8k cartridges from flash support.
(Atari Basic Rev.C / Assembler editor / Altirra Basic)
Changed, (c) mr.atari 2018
Changed, upgraded to include latest shipping firmware.

Tested on Altirra 3.00 and real hardware "600XL", "800XL" and "800XL in 48k 400/800 configuration".
For as I can see now, it does the trick.
If you find issues, please be so kind and drop me a pm or email.

To work on the 400/800, you need to change the cartridge-slot internally.
MyIDE-][ does not work without the PHI2-signal.
Pin "S" has RAS connected and needs PHI2
Its an easy fix, see here:
https://www.wudsn.com/index.php/product ... ri-800-fix

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/