It is currently Mon Dec 18, 2017 11:38 am




 Page 1 of 1 [ 7 posts ] 
Author Message
 Post subject: Observations about MyIDE II
PostPosted: Sun Sep 17, 2017 8:50 pm 

Joined: Sat Sep 16, 2017 2:30 pm
Posts: 6
Hello,

I have recently purchased the MyIDE II cartridge and started to use it on my Atari 130XE. As I started using it, several observations came to mind and I wanted to share them, noting that I searched for them in the forum but did not find the answers I was searching for.

1- Why does the MyIDE II not support CAR files? It is a very arduous task to have to convert .CAR files to .BIN/.ROM every time even with the AtariAge Atari ROM Maker software.
2- Very important programming languages such as Basic XE, Basic XL, and Action! all did not work despite them being in .ROM format. Did anyone else have a similar problem? Was there any work around solution?
3- The FAT32 partition procedure described by AtariMax https://www.youtube.com/watch?v=YQodgRABCUA is a little different from what I went through (I think the firmware update caused some differences). I wanted to share that I was able to follow up with the video by setting all the flags (i.e., HFI) to the partition.
4- Finding osb.bin and mathpack.bin was a task. I wish there was like a Quick Start documentation for those who are either lazy or are not Atari Computer savvy to know all the details and yet want to enjoy their Atari old days.

Sometimes I noticed that pressing the Help key (while in BASIC) will take me directly to the MyIDE Menu, then Reset, then Shift would take me to the MultiCart menu---while this is a very convoluted approach, it saves me from having to power-off-power-on the computer and is similar to what other cartridges have as a small switch on their multiboot cartridge (this approach did not always for example if I had loaded a game).

If you have succeeded in launching Basic XE or Action! using MyIDE II on Atari 130XE, please share with me what file types you used and the procedure you followed.


Offline
 Profile  
 
 Post subject: Re: Observations about MyIDE II
PostPosted: Mon Sep 18, 2017 1:36 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1258
Location: netherlands
atari65xenajm wrote:
I have recently purchased the MyIDE II cartridge and started to use it on my Atari 130XE. As I started using it, several observations came to mind and I wanted to share them, noting that I searched for them in the forum but did not find the answers I was searching for.

If you have succeeded in launching Basic XE or Action! using MyIDE II on Atari 130XE, please share with me what file types you used and the procedure you followed.



Look here for the modified roms for MyIDE-][
viewtopic.php?f=17&t=1572


Offline
 Profile  
 
 Post subject: Re: Observations about MyIDE II
PostPosted: Mon Sep 18, 2017 8:04 am 

Joined: Sat Sep 16, 2017 2:30 pm
Posts: 6
mr-atari wrote:
Look here for the modified roms for MyIDE-][
http://www.atarimax.com/flashcart/forum ... =17&t=1572


It worked. One observation about BASIC XE: I booted my Atari DOS XE diskette and it caused BASIC XE to freeze with a cursor at the upper left after reading DOS. Switching it to DOS 2.5, it worked and I got the Ready prompt.

Any thoughts or workaround about a way to reach the boot menu without having to power off/power on the computer?
Also, does MyIDE ][ run Diamond GOS 2 or 3? I have not been successful running it so far on my Atari 130 XE.


Offline
 Profile  
 
 Post subject: Re: Observations about MyIDE II
PostPosted: Tue Sep 19, 2017 2:51 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1258
Location: netherlands
BASIC XE, don't know. I only patched the OSS roms to MyIDE-][ roms....

Only when MyBIOS is still active, you can use shift+control+TAB or shift+control+CAPS.
This will restart the BIOS and you can go back to the cartridge.
When the BIOS is killed by some program, you have to switch off/on, the old fashion way....

Diamond GOS, I have no idea, never tried that, have to check.
Perhaps with a newer MyBIOS ? The stock MyIDE-][ comes with version 4.8

Check it out here (versions -4.8 , -4.9 and -RAM all on one) :
http://www.mr-atari.com/Mr.Atari/

Grtz,
Sijmen.


Offline
 Profile  
 
 Post subject: Re: Observations about MyIDE II
PostPosted: Sun Sep 24, 2017 7:33 pm 

Joined: Sat Sep 16, 2017 2:30 pm
Posts: 6
The MyIDE II documentation states that it is compatible with 8k/16k/"MyIDE-II Native" ROM/RAM Images.

What is a MyIDE-II Native image? Can this exceed 16k? If I have a 1MB ROM image, how do I make it "MyIDE-II Native"? Thanks.

Regards,
atari5xenajm


Offline
 Profile  
 
 Post subject: Re: Observations about MyIDE II
PostPosted: Wed Sep 27, 2017 3:52 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1258
Location: netherlands
I could have a look later this weekend.
Can you zip and upload this rom?
1mbit or 1mbyte...?

MyIDE2 is not compatibele with other atarimax.
8 or 16k. Banked upto 512kbyte.
Must obay the MyIDE2 bank-scheme.

Grtz. Sijmen


Offline
 Profile  
 
 Post subject: Re: Observations about MyIDE II
PostPosted: Wed Sep 27, 2017 7:14 am 

Joined: Sat Sep 16, 2017 2:30 pm
Posts: 6
mr-atari wrote:
I could have a look later this weekend.
Can you zip and upload this rom?
1mbit or 1mbyte...?

MyIDE2 is not compatibele with other atarimax.
8 or 16k. Banked upto 512kbyte.
Must obay the MyIDE2 bank-scheme.

Grtz. Sijmen


Thanks for your response. My question was hypothetical---I was thinking of a 1 MB (AtariMax 8 mbit) also known as a cartridge type 42. I do not have a cartridge image as such.

Best regards,
atari65xenajm


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 7 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron