Atarimax Product Discussion Forums
https://www.atarimax.com/flashcart/forum/

strange error message
https://www.atarimax.com/flashcart/forum/viewtopic.php?f=17&t=3514
Page 1 of 1

Author:  brenski [ Wed Oct 23, 2019 5:18 pm ]
Post subject:  strange error message

when trying to load

any of the following (stereo) files
Draconus.atr
zybex.atr
i get following:

"error loading os-b rom image
press any key to continue"

i've tried this in three different XLs - stock 800xl, 512k 800xl and U1mb 800xl

same error every time

Author:  mr-atari [ Thu Oct 24, 2019 1:27 am ]
Post subject:  Re: strange error message

For loading ATR files, you need the two Atari 800 OS files in the root of your card.
They are OSB.BIN and MATHPACK.BIN
They are needed by the fatloader to patch the XL-OS for ATR-support.
That is all.

Grtz,
Sijmen

Author:  brenski [ Thu Oct 24, 2019 1:33 am ]
Post subject:  Re: strange error message

ah, thanks. brilliant.

where can I find these?

Author:  mr-atari [ Thu Oct 24, 2019 1:50 am ]
Post subject:  Re: strange error message

Here you are.

:-)

Author:  mr-atari [ Thu Oct 24, 2019 1:52 am ]
Post subject:  Re: strange error message

Please note that loading ATR-files is less compatible then loading XEX-files.
This because the ATR-loading routine is patched into the OS and runs from RAM below OS.
Any program having access there will break it.

Grtz,
Sijmen.

Author:  brenski [ Thu Oct 24, 2019 7:14 am ]
Post subject:  Re: strange error message

thanks

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/