It is currently Wed Jul 18, 2018 10:47 pm

All times are UTC - 5 hours




 Page 1 of 1 [ 4 posts ] 
Author Message
 Post subject: Bug Report: QMEG and Flash Cart
PostPosted: Sun Aug 17, 2003 5:06 pm 

Joined: Sun Aug 17, 2003 4:55 pm
Posts: 1
Howdy *.*!

Just got my new flash cart and it rocks!! yeah!

but here are a few comments: The unix/linux installation is much harder than the windows version. at the end, i got it working with several "downgrades" (libc4 !!! argh!!!) for the rusty linux port of tasm. Also the perl script needed an additional package called "libcompress-zlib-perl", but it can be easy installed by using debain apt-get.

I think, these facts could be mentioned in the manual. Also finding the linux- tasm is not easy, because the website of the developers is down!!

however, the first thing I tried to upload to the cart was "Zork I". I got the image form TXG's server, everything went fine, except that I had to switch to the standard xl/xe operating systems. since, qmeg is much better than every other os, it's rather annoyoing to turn it off, when using the flash cart.

steven, could you check this bug? is it possible to "soft patch" the cart, or is it something to the internal construction of the cart?

\twh/f2


Offline
 Profile  
 
 Post subject: Re: Bug Report: QMEG and Flash Cart
PostPosted: Sun Aug 17, 2003 10:39 pm 
ERROR AT LINE 0
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1036
Location: Cleveland, Ohio
twh wrote:
Howdy *.*!

Just got my new flash cart and it rocks!! yeah!

but here are a few comments: The unix/linux installation is much harder than the windows version. at the end, i got it working with several "downgrades" (libc4 !!! argh!!!) for the rusty linux port of tasm. Also the perl script needed an additional package called "libcompress-zlib-perl", but it can be easy installed by using debain apt-get.

I think, these facts could be mentioned in the manual. Also finding the linux- tasm is not easy, because the website of the developers is down!!


Do you have a link to the old free version of linux TASM? I would like to port it to a newer, free assembler but I cant find one compatible with TASM syntax.

I will add information about the Compress::Zlib module. I thought it was installed as part of the base Perl package, but perhaps it comes with the CPAN modules.

twh wrote:
however, the first thing I tried to upload to the cart was "Zork I". I got the image form TXG's server, everything went fine, except that I had to switch to the standard xl/xe operating systems. since, qmeg is much better than every other os, it's rather annoyoing to turn it off, when using the flash cart.

steven, could you check this bug? is it possible to "soft patch" the cart, or is it something to the internal construction of the cart?


The --diskpacker carts patch the OS so there has to be a seperate patch set for different OS roms. I will load up QMEG and see if I can add a patch set for it to the --diskpacker driver.

Once there is a correct OS patch set for QMEG a new programming image can be built and the cartridge re-programmed.

Steve


Offline
 Profile  
 
 Post subject:
PostPosted: Tue Aug 19, 2003 4:47 am 
User avatar

Joined: Sun Aug 10, 2003 8:20 am
Posts: 33
Location: The Netherlands
Hi Steven,

Is it possible to release a tech-doc how the OS needs to be patched. There are lot's of different OS systems.

Qmeg 3.2 is mostly used by people, only users with a Black-box and other things use version 4.04
These are the original QMEG's not the patched versions from Poland they have there own numbering of the OS so for example a Polish 4.1 is a patched 3.2 version. I have many different versions of Qmeg.

TXG/MNX


Offline
 Profile  
 
 Post subject:
PostPosted: Wed Aug 20, 2003 4:37 am 
ERROR AT LINE 0
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1036
Location: Cleveland, Ohio
TXG/MNX wrote:
Hi Steven,

Is it possible to release a tech-doc how the OS needs to be patched. There are lot's of different OS systems.

Qmeg 3.2 is mostly used by people, only users with a Black-box and other things use version 4.04
These are the original QMEG's not the patched versions from Poland they have there own numbering of the OS so for example a Polish 4.1 is a patched 3.2 version. I have many different versions of Qmeg.

TXG/MNX


Is 3.2 on your FTP site?

I could write a document on how to patch the standard XL/XE OS but that wouldnt be of much use since those are already done ;)

I'm thinking QMEG probably uses up all the 'extra' space in the OS area for its own enhancements. If thats the case it will be hard or impossible to make a patch for it that does not interfere with some other feature.

A option for people who use this OS is to always use the -osb option until a patch is available. That will replace the installed OS with the pre-patched Atari 800 OSB OS.

This is not optimal though because in a multi-cart you lose 8K of space for programs and some picky games will refuse to run on OSB.


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron