Atarimax Product Discussion Forums
https://www.atarimax.com/flashcart/forum/

ATASCII characters
https://www.atarimax.com/flashcart/forum/viewtopic.php?f=5&t=1655
Page 1 of 1

Author:  mmoec [ Tue Sep 23, 2014 6:57 pm ]
Post subject:  ATASCII characters

Hi

I'm trying to figure out how to print ATASCII characters in the true type mode. I want to create a book of some of my old basic programs, but the program listings keep printing these weird characters whenever an ATASCII or an inverse video is encountered.
The Epson emulated printer will print inverse video, but strange things happen when trying to print ATASCII.
Does anyone know of a fix for this issue?

Thanks

mmoec

Author:  classics [ Wed Sep 24, 2014 3:10 am ]
Post subject:  Re: ATASCII characters

Do LPRINT "<ESC><ESC>!A" to change to full ATASCII mode.

Then LIST P: to print the listing.

Where <ESC><ESC> means press ESC twice to produce the ESCAPE arrow on screen.

Steve

Author:  mmoec [ Wed Sep 24, 2014 8:47 pm ]
Post subject:  Re: ATASCII characters

Hi Steve, thanks for the quick response.

The LPRINT command seems to work for the Epson MX-80 emulator, but not for printing to true type...still getting the same weird characters instead of the ATASCII. LPRINT did solve another issue though. I was unable to print to true type at all after I tried to print to the Windows Print Driver (Raw Spool), but by using LPRINT first I can again use true type.

Author:  classics [ Thu Sep 25, 2014 7:47 am ]
Post subject:  Re: ATASCII characters

TrueType will only be able to render characters that exist in the TrueType font. There are a couple ATASCII TrueType fonts floating around, but other fonts will have symbols and other stuff in those characters.

For true ATASCII you would need to use the MX-80 mode, then print it to a PDF file or something like that to save a copy suitable for printing.

Steve

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/