Atarimax Product Discussion Forums
https://www.atarimax.com/flashcart/forum/

ProSystem software & XF551 problems
https://www.atarimax.com/flashcart/forum/viewtopic.php?f=5&t=884
Page 1 of 1

Author:  jg [ Wed Nov 18, 2009 6:10 pm ]
Post subject:  ProSystem software & XF551 problems

Hi all,

I've used the ProSystem off and on for years, but currently going through a large batch of old disks using an XF551 drive.

The problem is that both sides of these disks were written to on a 1050; so the disk was flipped over when using the reverse side. This, therefore, is not the kind of double-sided disk an XF551 would have created. And therefore the XF551 can't read the reverse side unless you physically turn the disk over.

So the ProSystem software thinks that the XF551 has seen a double-sided disk and tries to make an ATR image of both sides of the disk in one sweep. As soon as it gets to the second side, the drive starts to chug and eventually ProSystem gives up. And deletes the entire image.

Is there any way of getting around this problem? I can't find anyway to tell the ProSystem software to ignore the XF551 B side.

Thanks for any help or thoughts,
Joel.

Author:  classics [ Thu Dec 03, 2009 3:26 pm ]
Post subject: 

I emailed an update on this I believe. If it didn't work please let me know. :D

Thanks

Steve

Author:  jg [ Thu Dec 03, 2009 4:37 pm ]
Post subject: 

Thanks Steve, it worked a bunch. I got through my disks in no time at all with your help!

Author:  Triads [ Wed Jan 20, 2010 9:50 am ]
Post subject:  Re: ProSystem software & XF551 problems

What was the solution?

Author:  jg [ Wed Jan 20, 2010 4:24 pm ]
Post subject:  Re: ProSystem software & XF551 problems

Steve sent me a special version with which I could force ProSystem into single-sided operation when using the XF551.

Author:  Triads [ Thu Jan 21, 2010 7:12 pm ]
Post subject:  Re: ProSystem software & XF551 problems

Was that implemented in the newer ProSystem? Isn't that an option that would benefit everyone?

Author:  bfollowell [ Thu Dec 13, 2018 3:25 pm ]
Post subject:  Re: ProSystem software & XF551 problems

Hey Steve, I've ran into this very same problem. While almost all of the disks I'm trying to image are from my college years thirty years ago, most appear to be reading really well. Hardly any bit rot or other issues. However, I didn't have my XF551 until long after college and I never created any new disks with it. All I had in college was a Rana 1000 drive. It was a DD drive, but not DS. Many of those images should be double-density, but none should be true double-sided. I was a cheap college student, so I clipped the side and used the back side by flipping the disks, but that's not really a "true" double-sided disk and I wouldn't think they should be showing up as double-sided to ProSystem.

All the disks that exhibit this problem show as [Drive 1] 2 Side(s), 40 Tracks, 18 SPT, 256 BPS. The regular disks that seem to work well say 128 BPS. Many of these are actually the back side of disks that read just fine on the front side.

I'm running the trial version of v3.0.2 if that helps any. Was the fix that you sent jg ever added to the subsequent versions? From the copy window, options on the right, I see "Do not probe for or use drive enhancements" but with the exception of "Continue on read errors", all of these options are grayed out. I'm assuming they're only part of the full version.

Thanks Steve!

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/