Atarimax Product Discussion Forums

Need help restoring MyDos to 16meg partition
Page 1 of 1

Author:  8-bit [ Fri Feb 28, 2014 11:47 pm ]
Post subject:  Need help restoring MyDos to 16meg partition

I inadvertently hit Copy from the dos menu and overwrote my SYS files. When I changed to another partition and tried to write Dos files to disk, I kept getting an error 162.
This is on a 512meg SD card with MyDos single, 16gig MyDos with lost MyDos booting capability (the one I get the error on, 2 PicoDos 16meg partitions, and an enhanced MyDos with PicoDos installers etc.
If I delete the bad 16gig partition, will it effect the other partitions?
And can I create a new 16gig partition in the same area, write MyDos to it, and copy over the other files that were on it from a backup I made of it?
I do not think I can use a disk copy utility to to restore that partition from the backup.

Anyway, input is needed on how one would get that partition with the messed up MyDos restored to a bootable MyDos partition!

Author:  mr-atari [ Sat Mar 01, 2014 2:43 am ]
Post subject:  Re: Need help restoring MyDos to 16meg partition

First: what version of MyIDE/MyBIOS are you running?
So I can be more specific.

But in a nut-shell:
You can simply disable IDE, boot from floppy with the correct DOS, enable IDE and write DOS/DUP to the partition in question.
Be sure you set disk size with "O" if needed.

You do not need to delete the partition, a format from DOS will do fine.

Author:  8-bit [ Sat Mar 15, 2014 4:24 pm ]
Post subject:  Re: Need help restoring MyDos to 16meg partition

Running MyBios 4.7.
On further investigation, even though the partition manager is showing the partition as being 16megs, and it is nowhere close to being filled with files and directories, I noticed that Mydos now reports the free space on that drive/partition as being 18.
So that was the reason for the #162 error.
So I tried deleting the files in a directory on that drive and then trying to write DOS to it.
The write completed with no errors but the drive still fails to boot stopping at a blank screen.
I am now to the point of formatting said partition with correct parameters set up as to sectors and density.
I will then try writing DOS to it again and seeing if it boots.
From there, it will be a matter of restoring all directories and files excluding DOS.SYS and DUP.SYS.
Also, when accessing the partition utility by pressing help, I am not taken back to the DUP.SYS menu and instead I see a black screen.
Could it be that I have to start over and reflash MyBios to the My_IDE cartridge?

Author:  mr-atari [ Sun Mar 16, 2014 2:23 am ]
Post subject:  Re: Need help restoring MyDos to 16meg partition

Not sure what the latest on the forum is, currently MyIDE-][ is the standard and I'm working on that the last 12 month.....
Aha, last version is 4.8.05 :-)
MyBIOS versions are downwards compatible, so you can safely re-flash the this version (you need the -FE)

Most of the times, MyDOS is screwed-up.
Use the O parameter to re-configure the size of the drive, then format/write dos to it.
You loose all the files.
But it should be read-able, so you can backup the files either on the atari or on the PC using myide-manager.

Author:  8-bit [ Sun Mar 16, 2014 1:30 pm ]
Post subject:  Re: Need help restoring MyDos to 16meg partition

Before I reflash with the newer BIOS, I want to make sure I do not loose Atari Basic c and assembler editor from the My_IDE menu.
With the cartridge installed, one can not just plug in their assembler editor cartridge.
I will download the current My_BIOS though and after flashing, access the partition editor and press ESC and then SAVE to make sure my partition tables are updated to the new version as stated in another post.
I also will keep you updated and I already have a backup of that partition as an atr file on my PC that I used aspeqt to create.

I just noticed I see no sign of an option to load Atari Basic c or assembler editor on the screen shown. So how would I use the revised version on an 800 if I wanted to boot with Basic?

Author:  8-bit [ Sun Mar 16, 2014 9:30 pm ]
Post subject:  Re: Need help restoring MyDos to 16meg partition

I am back after reformatting the 16 meg partition, writing MyDos to it, creating the sub-directories, and copying the files from a backup atr file I had stored on a flash drive using aspeqt.
The free space on the drive/partition again appears to be correct and I can again add more programs in more directories as well as do a little programming on the physical atari.
I also use this MyIDE cartridge with an atari 800 and so that is why I want to retain a MyIDE menu that includes atari basic and assembler editor.
It would have been nice to have an external MyIDE cartridge designed with a cartridge extender allowing the user to use their programming cartridges such as Action!, Some Basic versions, forth, pascal, etc.
But I do not know what would have had to be changed in the firmware to be able to accomplish such a feat.
Currently, I have one of my physical drives set up as D3: and bypass that when I set up partitions with MyBIOS.
That way, at least I can use my programming cartridges with D3: and be able to copy programs I have made to the plugged back in MyIDE and associated drives it interfaces to.
So for now, I am back up and running.

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group