It is currently Sun Oct 17, 2021 1:41 am




 Page 1 of 1 [ 9 posts ] 
Author Message
 Post subject: Internal MyIDE sits at version screen
PostPosted: Thu Sep 02, 2021 1:28 pm 

Joined: Tue Aug 17, 2021 1:26 pm
Posts: 16
I installed the MyIDE internal (just arrived in the mail)
Installation was a breeze.

I booted into the fdisk utility, followed the instructions here: https://www.atarimax.com/myide_old/docu ... pter1.html
Everything seemed to work fine. I partitioned the disk; and it rebooted as expected.

but now I get just the version showing on the screen and nothing more.

Ideas on how to get past this?


There are images and/or files attached to this posting. You must be logged-in to view or download this content.


Offline
 Profile  
 
 Post subject: Re: Internal MyIDE sits at version screen
PostPosted: Fri Sep 03, 2021 2:28 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1431
Location: netherlands
This is the "wait for ready" screen.
So, the OS is waiting for the IDE/CF to become ready.
This takes 5 seconds maximum, after that it boots into memo-pad (if I remember correctly).
4.3I is ages ago for me....;-)
Type something, if it appears on the screen it's in memopad.
remember to hold option to ENABLE basic.

Or, the partition you made as D1: has not been setup correctly.
Can you give a screenshot with FDISK loaded?
So I can see the partition information.

It's a bit of a chicken/egg problem here.
What I normally did, was creating a D2:, boot MyDOS over SIO, and write it to D2.
Re-enter FDISK, swap or change D2 to D1, save/exit.
Now you boot from IDE.
Set the correct drive-size with O.
Write DOS again to D1: to save this new configuration.
Setup completed.


Offline
 Profile  
 
 Post subject: Re: Internal MyIDE sits at version screen
PostPosted: Fri Sep 03, 2021 12:10 pm 

Joined: Tue Aug 17, 2021 1:26 pm
Posts: 16
I cannot seem to get to the myide fdisk

When I initially installed the MyIDE (a couple of days ago), I was able to FDISK the SD card - no problem. It was after that initial reboot that these things happened.

My setup:
Atari 800XL with MyIDE Internal
MyIDE to IDE->SD Interface (with external power supply)
SD Card (I've tried a few)

Tried:

Setting the jumper for "rescue" (is there information about how to factory reset the MyIDE?)
- Nothing happened; probably because there is an additional step I do not know about.

Attaching a known working SIO2USB to a PC and tryied to boot from RespeQT
- Not booting from RespeQT; continues to give the version number, WaitForIDE; then restarts and same thing over and over

Put a new SD card into the adapter
- continues to give the version number, WaitForIDE; then restarts and same thing over and over

I really appreciate the help here.


Offline
 Profile  
 
 Post subject: Re: Internal MyIDE sits at version screen
PostPosted: Fri Sep 03, 2021 1:21 pm 

Joined: Tue Aug 17, 2021 1:26 pm
Posts: 16
UPDATE: with the new SD card; it eventually goes to FDISK; once i follow the instructions; I am back at firmware version and WaitForIDE

Trying with 2 different spinning disks connected directly to the MyIDE ; it is doing the Version+Wait+reboot over and over.

Also: Sometimes, I am able to power off and on the machine, holding option, and it goes to a ready promp.
Anything I type gives me "Error - 2"


Offline
 Profile  
 
 Post subject: Re: Internal MyIDE sits at version screen
PostPosted: Fri Sep 03, 2021 1:59 pm 

Joined: Tue Aug 17, 2021 1:26 pm
Posts: 16
UPDATE: I finally got it.

I think the issue I am running into is that the Atari it is in has a 256K upgrade in it.
It requires a full minute of being powered off to discharge the DRAM.
Also; I was over thinking. When you are in MyDOS via APE or *speQT for the first time, re-enabling the MyIDE disk SHIFT+CONTROL+R might take a couple of tries. At least for me. This lead me to try to O/Change disk 2, 3, etc. until I realized that it might take a try or two to reenable the myide drive. once it was there, it was awesome.

Now on to fixing my warp mod :)

Thank you!!


Offline
 Profile  
 
 Post subject: Re: Internal MyIDE sits at version screen
PostPosted: Sat Sep 04, 2021 2:03 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1431
Location: netherlands
Yes, you should remember that OPTION is reversed in the 4.3 BIOS.
and FDISK is a replacement of the selftest.

So when you cycle in the bootup-screen, IDE has nothing to boot and tries again.
Pressing OPTION at this time, enables BASIC and it will go there.
Also the hot-keys are present, so pressing shift+control+D (disable IDE) will let you boot over SIO.

To enter FDISK: Boot the computer into BASIC or with a language like assembler inserted.
Type BYE to exit the language and enter FDISK.

4.3 is an early and crude (but very stable) BIOS to have IDE-support.

With the rescue ON, you have disabled the 4.3 BIOS plus the IDE-port.
So basically you are running a stock machine with no IDE.


Offline
 Profile  
 
 Post subject: Re: Internal MyIDE sits at version screen
PostPosted: Sat Sep 04, 2021 11:15 am 

Joined: Tue Aug 17, 2021 1:26 pm
Posts: 16
Do you recommend I stay with 4.3, or upgrade to a newer version?


Offline
 Profile  
 
 Post subject: Re: Internal MyIDE sits at version screen
PostPosted: Sun Sep 05, 2021 1:25 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1431
Location: netherlands
I think the 4.3 version for now, will suite all your needs.

Reprogramming to 4.8 I need to dig up.....
Plus, the menu structure is loaded from IDE, so beside updating the flashrom to 4.8, you need to install the menus for 4.8 on IDE.

But all info is (or should be) in the update topic.
The internal kit needs the -RI version of the BIOS.
viewtopic.php?f=7&t=1318


So, let's stay here for a while.


Offline
 Profile  
 
 Post subject: Re: Internal MyIDE sits at version screen
PostPosted: Sun Sep 05, 2021 8:34 am 

Joined: Tue Aug 17, 2021 1:26 pm
Posts: 16
will do! thanks


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 9 posts ] 


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron