Atarimax Product Discussion Forums
https://www.atarimax.com/flashcart/forum/

MyIDE plus FLASH cart freeze/hang issues
https://www.atarimax.com/flashcart/forum/viewtopic.php?f=7&t=2375
Page 1 of 1

Author:  matsadona [ Fri Mar 02, 2018 9:59 am ]
Post subject:  MyIDE plus FLASH cart freeze/hang issues

Hi

I'm late to the game with and old MyIDE plus FLASH cartridge from 2005 that I got in another deal wit lots of old Atari software. Now I finally decided to try it and also bought a 64MB DiskOnModule for this purpose.
From the beginning there was an older software, 3.2F, and I also noticed freeze and stability issues that I was hoping a re-flash would sort out.
And this version wasn't the same as described in the documentation I decided to flash it with the newer version.

Downloaded the 3.5F version from this forum and flashed the cart (with the ATR loaded via USB/SIO) successfully.
Unfortunately the freeze/hang issue got worse with the new version. Usually it hangs in the root menu after just a few seconds. You can see when the scrolling cursor stops and then the menu doesn't respond to any input. Sometimes I manage to go to the next menu, but as soon as I select any of the applications it hangs.

For the record the computer (130XE) is working fine with other game cartridges, so I would assume that both the connector and computer is good.

I suspect that there might be a timing issue rather than a flash memory issue (since the programming goes fine without any errors). I have unplugged and replugged both the flash and SPLD circuits, but no improvement.
Can the SPLD be re-programmed? Are there other things to check? Or should I just declare this unit as more or less dead in the water?

Author:  matsadona [ Fri Mar 02, 2018 10:03 am ]
Post subject:  Re: MyIDE plus FLASH cart freeze/hang issues

Added some screenshots.

Author:  mr-atari [ Fri Mar 02, 2018 12:47 pm ]
Post subject:  Re: MyIDE plus FLASH cart freeze/hang issues

viewtopic.php?p=9942#p9942

This is really an oldie....
The room for the 2 logic chips was only on the first run.

Try the link above, that is the latest version.
Also dig into the stability thread, page 4 has some info on how to mod your PCB.

Problem is the DOM.
Why not IDEtoCF and use a trancend 80x 1gb.
These are the best for the old myide-1

Succes,
Sijmen.

Author:  matsadona [ Sat Mar 03, 2018 3:22 am ]
Post subject:  Re: MyIDE plus FLASH cart freeze/hang issues

Thanks for your reply and input. I'll try that other version and go through the other posts.

By the way, the DOM wasn't connected when I experienced the issues reported. But I will for sure consider an IDE->CF solution if I get this working properly.

Author:  mr-atari [ Sat Mar 03, 2018 3:37 am ]
Post subject:  Re: MyIDE plus FLASH cart freeze/hang issues

OK, if the DOM was not connected:
There is a problem loading the OS from FLASH.
First try the 4.8 version and see if that boots, also without the DOM.

In the boot-screen some items are RED, since no IDE-device can be detected.
Press/Hold OPTION and check if you get into BASIC.

This new flash-content uses the atarimax-menu.
Created with the (free) atarimax studio software.

Later,
Sijmen.

Author:  matsadona [ Sat Mar 03, 2018 1:57 pm ]
Post subject:  Re: MyIDE plus FLASH cart freeze/hang issues

Perhaps there is something wrong with my 130XE computer after all - when I tried to flash the cartridge I got a verify error and "Programming operation FAILED!".
Did however manage to flash it successfully with a 600XL machine.
This version seems to work on my 130XE and I'm able to navigate the menu and start some applications. Now I just need to go through the documentation and learn how to use this thing, before I can verify if it is fully working or not.
Thanks so far for all help.

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/