Atarimax Product Discussion Forums

Problem with 4.3I EPROM and 800 XL
Page 1 of 2

Author:  KrzyInuYasha [ Fri Sep 05, 2008 7:54 pm ]
Post subject:  Problem with 4.3I EPROM and 800 XL

OK I have searched about every board i could find and haven't found a fix to this issue I am having.

I have built a homemade MyIDE interface and am using 2 AM27128A-1DC EPROMs and a AM 27C128A-2 EPROM for my OS PROM testing.

I have burned both the 4.3I and 4.3E ROM images and i can get the 4.3E to boot every time i burn it to a EPROM and have verified my IDE interface is working with it. For some reason though no matter how many times or ways i burn the 4.3I ROM all i get is a dark reddish-brown screen on boot up and none of the by pass keys will get me past this screen.

Now while i don't mind using the external version I am running into power issues with my current CF setup (even with the pin 20 mod) and would still like access to the cartridge port on my 800 XL with the MyIDE interface.

I am not sure what the couse of this problem is i am using the 4.3 ROMs posted on this board so they should be working. i have also re-D/L them just to make sure it wasn't a corrupted image and still no luck.

Any help on this would be greatly appreciated.

Programmer: Needham's SA-20 via Serial and Parrallel
EPROMs: AM27128A-1DC, AM27C128A-20
Atari: 800 XL Stock
MyIDE: Home made with 74F** chips and verified working via cartridge port


Author:  roye [ Sat Sep 06, 2008 1:59 pm ]
Post subject:  Internal


I had a simular problem until I mounted the internal myide and had a harddrive attached with external power going to the harddrive..
Of course my first effort was with version 31i before the 74f series chip upgrade.
Good Luck.


Author:  KrzyInuYasha [ Sat Sep 06, 2008 4:59 pm ]
Post subject: 

That's the thing though is I tired that all ready and still got no boot-up of the OS. unless I some how manage to get the pin-out wrong to the CPU and I am sure I didn't. I will try this again in a little bit but i have a feeling I will get the same screen. though any other suggestions or help will still be appreciated.


Author:  mr-atari [ Mon Sep 08, 2008 4:09 am ]
Post subject: 


To verify if the problem lies with the IDE or EPROM, please
insert the EPROM 4.3I and do not connect the interface.

For example, you can remove the cartidge-interface and
only replace the EPROM from 4.3E to 4.3I

Now try and boot the Atari. It should boot as normal.
IDE is not detected and not used, that is all.


Author:  KrzyInuYasha [ Tue Sep 09, 2008 3:21 am ]
Post subject: 

Actually I started out that way before I even started to build the IDE interface just to make sure i could burn a EPROM and get it to boot. Since then I've tried booting the EPROM with and with out the IDE interface and the only one that will boot is the 4.3E. 4.3I just won't boot at all every time i get a dark reddish-brown screen and nothing else.

EDIT: just a side note i've tried 3 differant EPROMs that i have verified working with 4.3E just in case it was a chip problem and all 3 give the same issue.


Author:  mr-atari [ Tue Sep 09, 2008 12:12 pm ]
Post subject: 

very strange.
in anycase, here is the original file.
just incase the download-version has gone bad (if that is possible...)
let me know if this one boots....


Author:  KrzyInuYasha [ Wed Sep 10, 2008 3:39 am ]
Post subject: 

Well after trying another 5 chips still no go even with the new file. What I have figured out is that the Atari is acting as if there was no ROM at all. I did a quick test and booted the system real quickly with out any OS chip in it. I got the same screen as when i have a chip in with the 4.3I OS. So for some reason the system can't find the OS or what ever the boot code in the ROM is to load the OS.

At this point it's either some thing stupid I am doing on programming or my particular Atari. Below is the settings used when programming the chips. I use these for both the 4.3E and 4.3I ROMs and get working 4.3E all the time. please let me know if any of that is wrong and what needs fixed on it.

Buffer Options:

Set Pointers
Buffer : 00000-03FFF
Device: 00000-03FFF
Length: 04000

Split Options
Factor: 1
Position: 1

Set Options
Sets: 1
Position: 1

File Options:

File Pointers
Buffer: 00000-7FFFF
File: 000000-07FFFF
Shuffle: 1

File Type: Binary

Buffer all ways cleared before File Read with 00

Program Device:

Intelligent 1ms 3x

Not sure if this matters but here's the numbering and dump of the original OS PROM from my Atari.

Top Side:

Bottom Side:

-The red pulp covering a brick wall

Author:  mr-atari [ Thu Sep 11, 2008 5:31 am ]
Post subject: 

Hmmm, I'm totally puzzled.

I have tested the uploaded file first on my 800xl with flashrom, it worked.

Perhaps we are overlooking indeed something simple.
The only difference between I/E is the addressing of port D1xx instead of D5xx.
You haven't got by any chance a PBI device hooked to your atari?
That will give a hardware conflict.

A standard 800XL with removed OS and inserted new OS (without IDE interface)
should boot as a standard system. The only difference is the inverted option-key.
(hold to enable basic)
No matter if you use 4.3I or 4.3E

Did you try the older 3.1 OS? Just out of curiousity. It's the previous version of the same OS.


Author:  KrzyInuYasha [ Thu Sep 11, 2008 6:23 am ]
Post subject: 

Nope no PBI or SIO devices hooked up. Just tried the 3.1I with the same results. Not sure what the deal is since this is a stock 800XL except for the S-Video 2.0 mod i did yesterday so i had an easier connection to my TV for testing (Test monitor i had for the Atari croaked finally). Looking at the MB there is a ink stamp of 30 JAN 1984 on one of the grounding/RF shielding plains and a silkscreen/Copper Etch of Chelco 1983 P/N: 150800011 REV. A2 800XL in the upper right corner just under the SIO port.

Edit: Got to looking at a schematic of the XL because I noticed a cap on the POKEY and Joystick line was bad (Dried out/ruptured electrolytic) and wanted to replace it. At looking at it I was wondering if the Basic ROM would effect any of this since it's tied in with the OS ROM?

Author:  mr-atari [ Fri Sep 12, 2008 2:31 am ]
Post subject: 

Still very puzzled.....

After you get the brown/red screen, leave the atari on, hold (and keep holding select).
Press and release reset.
wait a second, now release select.
This will force the operating system to coldstart and reset all IO-chips.

The xl.rom you uploaded is the original rev_2 version from atari.
You burn the eprom correctly. The file is a binairy dump length 4000.

The basic rom is tied to the MMU, a bit of the pia-b port selects this rom when needed.
It's blended into A000-BFFF. Otherwise the MMU address ram.
The caps should not effect the Atari memory-map.
What happens when you boot with the 4.3I with a cartridge in the slot?

Back later,

Author:  mr-atari [ Fri Sep 12, 2008 2:59 am ]
Post subject: 

ok, i'm back ;-)

Just to be sure, I downloaded the 4.3I from this post.
Burned it into a AMD 27C128 12.7v EPROM.
Took a stock 800xl (PCB has a REV D stamp on it).
removed the original OS and put this one in.
It boots.......

Then I holded SELECT and powered up.
Screen stays black. This is a pitty, I hoped for a red/brown.....
Released SELECT and the system booted.

Now I'm 100% puzzled.
Can you check if the D1xx-pin from your 74LS138 is hooked to something?


Author:  KrzyInuYasha [ Fri Sep 12, 2008 4:35 am ]
Post subject: 

I am going to assume that the D1xx-pin is Pin 14 on the chip in which no it is not connected to any thing. also all tests I am doing is with out the IDE interface hooked up. as for the red/brown screen that is probably a variation due to my board revision or part of the BASIC ROM maybe. the code on the BASIC ROM chip is:

F807611 N8326
ATARI 1979

I'm sure that info is unneeded but at this point it's the only thing that I can think of that could cause an issue unless I have a bad chip some where and not know it. Or the revision on my Board is different in some way to cause the issue.

any way hopefully we can figure it out but unfortunately I'll be away for a while due to my grandfather being severely sick in the hospital and living 6 hours away means I'll be away until Tuesday night.

Author:  mr-atari [ Sat Sep 13, 2008 2:52 am ]
Post subject: 

Ok, no problem. I wish you all the best.

Send me a PM when you are back.


Author:  Wrathchild [ Sun Sep 14, 2008 3:45 pm ]
Post subject: 

Forgive the simplistic recommendation, you've probably tried this already.

I had a similar symptom, brown screen on powerup, when I first setup my MyIDE using a laptop hard-disk and the problem was that I had plugged the IDE cable around the wrong way on the drive end (as it uses extra connections for the power).

See my posts on this thread: ... opic=46316

Author:  KrzyInuYasha [ Sat Sep 20, 2008 11:22 pm ]
Post subject: 

::Bangs head repeatedly against a brick wall with metal spikes::

Well first off i want to thank those of you who tried to help me especially Mr-Atari. Then i want to apologize for wasting peoples time with this issue. I say this cause i figured out what my issue was. It was a mix of 20 year old hardware connected to a 5 year old PC and an operator who just assumed the ROM made it into the buffer completely :oops: . Needless to say after resurrecting a old P2 system with a Intel 440BX chipset (one of the best and most compatible IMO of that era of PCs) and Win98SE every thing worked as it should with no ROM transfer loss.

So any way thanks for all the help and hopefully i won't run into any other issues in getting this project finished up. If i do i prey it is not because of my own stupidity at least :roll: .

- Shaun

Page 1 of 2 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group