It is currently Tue Jul 27, 2021 4:55 pm

 Page 1 of 1 [ 3 posts ] 
Author Message
 Post subject: Transcend 256 MB still won't work!
PostPosted: Mon Jun 15, 2009 4:33 pm 

Joined: Mon Jun 21, 2004 7:53 am
Posts: 329
Here's a hoot -- my Transcend flash modules won't work, but my SimpleTech modules (again) work fine. Steve recently replaced the 74F245 with the 74LS, and that definitely helped, because previously, the SimpleTech modules also would not work, and they had worked well in my old cart.

I posted this shortly after getting the new style cartridge: ... .php?t=765

First, is there an issue with FDISK2 and the APELOADER? Whenever I launch FDISK2.XEX from the APELOADER, on the first launch it hangs after just starting to load. If I hit RESET, then with the second launch of the APELOADER, it loads correctly every time. (?)

Second, I have been using Cartridge Flasher version 3.5. Is that the best choice, or is the 4.4F supporting SD cards a better choice? If so, perhaps I'll just shelve the Transcend modules until 4.XF is closer to a release version. Where does 5.0 fit into all this? I know that after some initial MyDos ramdisk issues, I had a stable system with 5.0, and it definitely was faster than 3.5.

Third, which of Hias high-speed patches is the best to use? I previously used 1.10, then 1.20 which is the new patch that is for XE and MyIDE, IIRC. (I think I'm suffering from "version overload." :wink:

Sorry for all the questions, but I'd still like to get this flashcart system stable with the Transcend modules and (hopefully) faster-operating, too.


 Post subject: FDISK2 Won't work with 4.4F (NTSC)?
PostPosted: Tue Jun 16, 2009 6:26 am 

Joined: Mon Jun 21, 2004 7:53 am
Posts: 329
I flashed my cart with 4.4F (latest), and 4.4F recognized my SimpleTech module and partition just like 3.5F.

So I thought I'd try the Transcend CF module with 4.4F. But when I tried to load FDISK2 (November '08 download) Fdisk2 will *not* load using the APELOADER. As I said before, when using it with 3.5F, FDISK2 has to be launched twice, and will load only after hitting RESET. This reminds me of the ACTION! issue that clears an error from the flashcart load.

I tried several "RESETs" (Shift-Cntl-Tab, etc.) but it just hangs immediately after trying to start the load.


 Post subject:
PostPosted: Wed Jun 17, 2009 2:39 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1415
Location: netherlands
Hi Larry,

Yes, lot of questions, were to start.... ;-)

Versions: 3.x and 4.x are all CHS addressing IDE-drivers.
Were the 4.x have upgraded error-retry-logic and (since 4.4) SD support.

Versions 5.x and above are LBA addressed IDE-drivers.
Which are indeed faster then CHS. Simply because the atari does not
need to calculate the location of the sector. The IDE-logic can do this much

FDISK2.XEX: I do not recall that I have released a DOS-loadable version.
But perhaps I have a short memory at the present. The last stable version
is always included in the flashportion (x.xF) of the cartridge as in the
selftest area of the EPROM-versions (x.xI otr x.xE).

Compatibility: It could be that your module directs the MyIDE-OS to
directly boot from a paritition that is not valid and only contains garbage.
This will lockup surely. Perhaps you can try this; put the trouble module
in a PC and try to format it. When it works ok, you know it's fine. Then
use a sector editor to write all $00 zero's to absolute sector $0000. This
will erase any gargabe the atari reads as MyIDE-partition. Be sure you
access absolute sector $0000 and not relative. The relative sector is soft-
sector outside the boot sectors, just to prevent noobs to erase partition-information.

Cheers, later,

Display posts from previous:  Sort by  
 Page 1 of 1 [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 5 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: