It is currently Mon Nov 28, 2022 8:15 pm




 Page 1 of 1 [ 4 posts ] 
Author Message
 Post subject: Unable to enter diagnostic mode
PostPosted: Mon Aug 22, 2022 9:19 pm 

Joined: Wed Jan 19, 2022 2:26 am
Posts: 2
Hi there,

I'm having a problem getting into diagnostic mode with my Atarimax SD cartridge on my 2-port 5200.

Holding down fire on stick 1 while powering on gets to the rainbow Atari logo splash screen, but the line where the cartridge name would normally appear is corrupted with random characters. The diagnostic then proceeds to load, but the system locks up and the screen is filled with random graphics.

FWIW, the cartridge says it's running hardware 20200813, boot flash 20211021, menu 20190619, and firmware 20211103.

Am I doing something wrong, or does something else need to happen in order to run the diagnostics?


Offline
 Profile  
 
 Post subject: Re: Unable to enter diagnostic mode
PostPosted: Wed Aug 24, 2022 3:27 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1511
Location: netherlands
My diagnose would be, there is something wrong with your 5200.
Based on the corrupted message about the cartridge name.
Could be a RAM failure and with ram failure, you can not load anything, not even diagnostics...


Offline
 Profile  
 
 Post subject: Re: Unable to enter diagnostic mode
PostPosted: Wed Aug 24, 2022 9:05 pm 

Joined: Wed Jan 19, 2022 2:26 am
Posts: 2
mr-atari wrote:
My diagnose would be, there is something wrong with your 5200.
Based on the corrupted message about the cartridge name.
Could be a RAM failure and with ram failure, you can not load anything, not even diagnostics...


I understand where you're coming from, but I'm doubtful that it's a RAM issue. The only title I'm having trouble with is the built-in diagnostics on the Atarimax; every other cartridge image on it works fine (with the exception of BBSB, but that's expected).

Commercial cartridges also work without issue, at least based on the dozen or so I have to test with.

This console was extensively refurbished by me about a year ago, which included replacing the CPU (dead), POKEY (missing when I got it), and various discrete components. GTIA and ANTIC have been swapped into other systems and seem to be OK when run for extended periods. Running the PAM cartridge tests shows everything passing, and the machine has been dead reliable since being resurrected.

By no means am I dismissing the idea of a problem with the console itself; it's certainly possible. It just doesn't seem likely in this case.


Offline
 Profile  
 
 Post subject: Re: Unable to enter diagnostic mode
PostPosted: Thu Aug 25, 2022 2:34 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1511
Location: netherlands
In that case, I don't know, sorry.
I have the SD-version of the atarimax cartridge, so no way in testing.
Do you have the flash-content on file?
I can have a look on emulation where the system crashes.
What 5200-OS do you have installed?

Grtz,
Sijmen.


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 4 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron