It is currently Tue Oct 22, 2019 7:53 pm

All times are UTC - 5 hours




 Page 1 of 1 [ 6 posts ] 
Author Message
 Post subject: programmer not accepting maxflash driver, just a HID device.
PostPosted: Sat Dec 08, 2018 6:10 am 

Joined: Sat Dec 08, 2018 5:48 am
Posts: 5
So I got my maxflash programmer and 8mb carts today. the programmer detects as a vendor-defined device, I've installed the 64bit drivers for windows 10, downloaded the latest from here and tried those, even tried this on another machine. it always detects the same.

If I tell it to go use the maxflash.inf as the drive (the old windows I have a disk option). it says its not compatible with the device.

Its detecting as VID 10C4 and PID EACA

In the device events, it says this:-
Device HID\VID_10C4&PID_EACA\7&1e758adc&0&0000 was not migrated due to partial or ambiguous match.

Last Device Instance Id: HID\VID_056A&PID_0084&Col02\a&1ceacfe7&0&0001
Class Guid: {745a17a0-74d3-11d0-b6fe-00a0c90f57da}
Location Path:
Migration Rank: 0xF000F800FFFFF100
Present: false
Status: 0xC0000451

Any ideas?


There are images and/or files attached to this posting. You must be logged-in to view or download this content.


Offline
 Profile  
 
 Post subject: Re: programmer not accepting maxflash driver, just a HID dev
PostPosted: Sat Dec 08, 2018 6:25 am 

Joined: Sat Dec 08, 2018 5:48 am
Posts: 5
This has now been tested on 3 different machines, 2x win10 x64 and a win7 x64 machine.

Always detects as this HID device, and never accepts the driver as correct for the device.

My gut is telling me I have a blank programmer.


Offline
 Profile  
 
 Post subject: Re: programmer not accepting maxflash driver, just a HID dev
PostPosted: Sat Dec 08, 2018 9:36 am 

Joined: Sat Dec 08, 2018 5:48 am
Posts: 5
Here's my Device IDs panel. Based on the PID and VID in the driver, this isnt correct. (I've checked its this by unplugging).


There are images and/or files attached to this posting. You must be logged-in to view or download this content.


Offline
 Profile  
 
 Post subject: Re: programmer not accepting maxflash driver, just a HID dev
PostPosted: Sun Dec 09, 2018 3:00 am 
User avatar

Joined: Sun Nov 02, 2003 8:15 am
Posts: 1372
Location: netherlands
Strange, it should list under atarimax devices.

I am a noob when it comes to windows/pc's.....
But here is a screenshot of what I see in my device-list.


There are images and/or files attached to this posting. You must be logged-in to view or download this content.


Offline
 Profile  
 
 Post subject: Re: programmer not accepting maxflash driver, just a HID dev
PostPosted: Sun Dec 09, 2018 4:33 am 

Joined: Sat Dec 08, 2018 5:48 am
Posts: 5
Yeah, based on the info in the inf driver file, I'd expect the same. it is detecting two devices as per yours, just not with the correct VID and PID and its therefore not accepting the driver file, even when told to force it.


Offline
 Profile  
 
 Post subject: Re: programmer not accepting maxflash driver, just a HID dev
PostPosted: Sun Dec 09, 2018 4:35 am 

Joined: Sat Dec 08, 2018 5:48 am
Posts: 5
Just had a response from Steve, a small number of units went out with a broken firmware on it. He's shipping me a replacement unit.


Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 1 of 1 [ 6 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron