It is currently Sun Jul 12, 2020 8:40 am

 Page 1 of 1 [ 5 posts ] 
Author Message
 Post subject: NEW BUG found in 3.1
PostPosted: Wed Sep 19, 2007 3:45 pm 

Joined: Thu Feb 05, 2004 10:34 am
Posts: 259
Location: NL
Hi Folks,

In the tweaked 3.1 topic I wrote about (new) problems with my routine on FD00, but I guess this problem I have is a new bug.

This bug was not discovered before, because the MyIDE 3.1 could not copy between partitions at all.

I have not much information about it yet, because I have to sleep first, but I have this problem:

It is on SpartaDOS (3.3a) when I copy *.* files to another partition, and one of these files is above 32KB the destination directory I'm copying to is garbaged.

I have a dir on D1: called D1:>DOS>TOOLKIT>

In this dir I have the SpartaDOS toolkit files. Like, etc.
When I copy these files to D2:>test

The main directory of D2: is after the copying ok, but D2:>test is reading garbage.

When I copy files smaller as 32KB no problem happens.
Strange enough: when I copy only 32KB file, there is no problem. And when there is a selection (like copy *.com D2:) the problem seems not to happen.

Another thing: When I use the external copy program from BeWedos. Called ... there is also no problem.

So what is the internal copy command of spartaDOS doing, what causes this BUG. I think it is a bug, because this problem does not happen when I do the same command on SIO drives. Or when I copy to Ramdisk. It only happens on MyIDE.

I will make a test atr.

I hope some other people will try to reproduce the bug. Beware: your destination partition is gone after you tried this, so do not do it on partitions with important data.

I hope someone could test this also on MyDOS. I'm curious if the problem is there too.

It seems to be a combination of the internal copy command of SpartDOS and MyIDE. Since this problem is not on BEWEDOS it is very possible this problem isn't also on MyDOS, or other Dosses.

<ironic mode>But ofcourse... I'm a SpartaDos user, so the problem is on SpartaDos</ironic mode>

Thanks folks

 Post subject:
PostPosted: Wed Sep 19, 2007 8:32 pm 

Joined: Sat Sep 13, 2003 12:21 am
Posts: 251
It might be interesting to see if the same problem happens on SD partitions as well as DD ones. I don't have the 3.1 os on my 32-in-1 yet, so can't test it myself, and probably won't be able to until after next week.

MyIDE Tools
 Post subject:
PostPosted: Thu Sep 20, 2007 12:52 am 

Joined: Thu Feb 05, 2004 10:34 am
Posts: 259
Location: NL
i will try several things today.

in the other topic you asked me if it is easy to reproduce the bug. Yes it is.

When I use a directory with large files, it goes wrong sooner, and even results in Error 139.

I'll try:

1. this on SD too
2. to find out if it goes wrong on the reading OR on the writing
3. to find out what ram area SpartaDOS 3.3a uses with it's internal copy command. Perhaps above 32K it uses ram area, also used by MyIDE 3.1 data.
4. to find out WHAT is going wrong. It seems it does do all the copying right, but then screw up the directory table. I think, when I study the directory table (what data is there), I get to know more about this.
5. also MyIDE 4.3... perhaps this problem also exists there.

With my previous bug-find-process I discovered a very good test-help on this problems, is using a (very) large tekst document as file. When you are known with the tekst in this document you will recognise the data sooner, when it is in memory on places, where it shouldn't be stored.

Another option is a tekst doc with tekst blocks of exact 128bytes. Every block contains another character. This makes it possible to see WHEN it goes wrong. like this:

!!!!!!!!!!!! (128bytes)
"""""""""" (128 bytes)

So you can detect on what block of the txt file the read or write problems did occur.

It is interesting.
Perhaps I should try 4.3 first...


 Post subject:
PostPosted: Thu Sep 20, 2007 3:33 am 

Joined: Thu Feb 05, 2004 10:34 am
Posts: 259
Location: NL
Test with 4.3
No problems. 4.3 has not this bug.

Test with 3.1
Copy from DD -> DD = problem exists
Copy from DD -> SD = problem seems NOT to exist

I also tried this again with my LDA #$00 solution on C984, but the problem still exists then.

So I'm pretty sure this is a new problem. I think the word "bug" is wrong chosen by me. It seems to be a compatibility issue.

When you use BEWEDOS external copy command ( there is no problem.

(You could rename to and store it in the root)

I think this problem will not happen in other situations. It seems the internal copy command of spartados is incompatible with the MyIDE 3.1 system (using same (temp) bytes in ram perhaps).

I don't know if it is really needed to fix the whole OS for this, but it is important to know that the problem DOES exist!

Perhaps Stehpen J. Carden could take a look at the internal command "Copy"... or I could try to make the internal copy command doing nothing, to prevent problems.

I'll think that over.

 Post subject:
PostPosted: Thu Sep 20, 2007 5:26 am 

Joined: Thu Feb 05, 2004 10:34 am
Posts: 259
Location: NL

The problem is getting interesting.

Now I found a file that won't copy, even with the BeWeDOS copy tool.

It is called

It is a game. If you need this file to test, send me PM.

The file is 83966 bytes large.

It does work properly (copy) on MyDOS.

that is not a prove that there is nothing going wrong. Perhaps also on MyDOS there is a certain false sector written, but doesn't this matter for MyDOS.

It's hard to find out.

Display posts from previous:  Sort by  
 Page 1 of 1 [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 7 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: