It is currently Sun Dec 08, 2019 7:52 am




 Page 2 of 6 [ 86 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next
Author Message
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Fri Apr 15, 2011 7:55 am 

Joined: Thu Feb 05, 2004 10:34 am
Posts: 259
Location: NL
There are no capacitors at all in this interface. Indeed the first badge.

3 TTL
2 resistors
1 Led

That's it.
M.


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Fri Apr 15, 2011 8:02 am 
ERROR AT LINE 0
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1039
Location: Cleveland, Ohio
Try adding 0.1uf capactors across the power/ground pins of the TTL ICs.

Then add a 22uf capacitors across power/ground close to the card edge below the ICs, and one above, across ground/pin 20 at the base of the IDE connector.

Add a heavy ground wire from the ground of the IDE edge connector to the ground closest to the Atari edge connector.

Steve


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Fri Apr 15, 2011 3:14 pm 

Joined: Thu Feb 05, 2004 10:34 am
Posts: 259
Location: NL
@Steve

Hi, thanks a lot for this information. Will that cure the 'usual' instability? Is there any chance you could post a picture of that 'fix' you described above this post (with that 22uF capacitor and all that) to show how to do it exactly?

I can handle a solder iron rather well, but the chance that I solder the components on the wrong places is rather big :D

The 0.1uF capacitors part is clear to me. I know how to do that, and where to put them.

The 22uF is not completely clear. I don't have 22uF in store at the moment... only 10uF but I guess those won't do?

Greetz
M.


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Fri Apr 15, 2011 3:45 pm 

Joined: Thu Feb 05, 2004 10:34 am
Posts: 259
Location: NL
Two other questions:

1. I also have an original AtariMax 1Mbit Flash card with MyIDE. The one where there is room for the original TTL chips. This board has different layout (as far as I can see that) I can not find the connection pads A0, A1 and A2 on this older (original) board.

2. Will this fix (with that GAL) also work on the original non-flash based MyIDE?


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Sat Apr 16, 2011 3:13 am 

Joined: Thu Feb 05, 2004 10:34 am
Posts: 259
Location: NL
Thanks again!

Can I conclude that this also will work in the non-flash MyIDE then? When I find the right points on the oldest PCB, it will still work right?

Greetz
M.


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Sun Apr 17, 2011 2:38 pm 

Joined: Sat Mar 12, 2011 12:06 pm
Posts: 24
Steve, will this modification be done on every MyIDE cartridge in the future?


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Sun Apr 17, 2011 5:38 pm 
ERROR AT LINE 0
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1039
Location: Cleveland, Ohio
bytecat wrote:
Steve, will this modification be done on every MyIDE cartridge in the future?


I'd like to see if it works well for people before doing that, but I do already have some with the modification pre-installed.

If it works well then I will make a new PCB with the updated circuit.

Steve


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Sun Apr 17, 2011 5:42 pm 
ERROR AT LINE 0
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1039
Location: Cleveland, Ohio
Sysop*Marius wrote:
@Steve

Hi, thanks a lot for this information. Will that cure the 'usual' instability? Is there any chance you could post a picture of that 'fix' you described above this post (with that 22uF capacitor and all that) to show how to do it exactly?


10uF may work fine, it depends on how much power the IDE device is drawing when its operating.

If you post pictures of both sides of your MyIDE board I will suggest locations. I don't have the original MyIDE made by Sijmen to consider.

Steve


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Sun Apr 17, 2011 5:43 pm 
ERROR AT LINE 0
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1039
Location: Cleveland, Ohio
Sysop*Marius wrote:
Thanks again!

Can I conclude that this also will work in the non-flash MyIDE then? When I find the right points on the oldest PCB, it will still work right?


Yes, if it works well it should work well on any MyIDE.

Steve


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Sun Apr 17, 2011 5:45 pm 
User avatar

Joined: Fri Aug 29, 2003 4:37 pm
Posts: 229
Location: Arizona USA
Steve,

If I modify my existing MyIDE cart and trash it can I send it in for repairs.?

I have one of the newest MyIDE carts that doesn't work and one of the older types that works okay with several of my Atari setup's.



_________________
Roydea6
Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Sun Apr 17, 2011 5:58 pm 
ERROR AT LINE 0
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1039
Location: Cleveland, Ohio
roye wrote:
Steve,

If I modify my existing MyIDE cart and trash it can I send it in for repairs.?

I have one of the newest MyIDE carts that doesn't work and one of the older types that works okay with several of my Atari setup's.


This possibility is why I didn't want to post the instructions, but if it goes wrong for you send it in and I will try to fix it. :-)

If you are not confident with applying the fix yourself you can send the unmodified cartridge and I will send you back a new one that is pre-modified.

Steve


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Sun Apr 17, 2011 7:39 pm 

Joined: Mon Jun 21, 2004 7:53 am
Posts: 329
A related question... My new-style, clear cart appears to have glue on the shell pins that join the halves. (?) Are these glued or welded, and if so, how would one get them apart?
-Larry

roye wrote:
Steve,

If I modify my existing MyIDE cart and trash it can I send it in for repairs.?

I have one of the newest MyIDE carts that doesn't work and one of the older types that works okay with several of my Atari setup's.


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Sun Apr 17, 2011 8:14 pm 
ERROR AT LINE 0
User avatar

Joined: Tue Aug 05, 2003 9:55 am
Posts: 1039
Location: Cleveland, Ohio
The clear carts typically have glue on two of the small corner pins to keep the shell from coming open during normal use. Pull apart gently on the open end until they come loose.

The ones that are tacked shut may pop off when you pull the two halves apart. If that happens there should be a couple unglued pins on the other side to seal if you want to re-seal the cart to prevent it from coming open easily.

Steve


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Mon Apr 18, 2011 7:05 am 

Joined: Mon Jun 21, 2004 7:53 am
Posts: 329
Hi Steve-

Thanks. Yes, the shell popped open without damage, except to three of the four small pins as you suggested -- much easier than I had thought. While I'm at it, think I'll change out "Mr. Electric Blue LED." :wink:

-Larry

classics wrote:
The clear carts typically have glue on two of the small corner pins to keep the shell from coming open during normal use. Pull apart gently on the open end until they come loose.

The ones that are tacked shut may pop off when you pull the two halves apart. If that happens there should be a couple unglued pins on the other side to seal if you want to re-seal the cart to prevent it from coming open easily.

Steve


Offline
 Profile  
 
 Post subject: Re: Let's do something constructive about the MyIDE+F stabil
PostPosted: Thu Apr 21, 2011 2:21 pm 

Joined: Wed Mar 04, 2009 7:27 am
Posts: 98
Location: United Kingdom
Well, I applied this fix this evening and one out of six CF cards I tried is at least close to working now (I'm using the SDX driver, not the stock MyIDE OS, just to get that out of the way, since it's pointless fixing it up to work with the latter because I bought the interface to aid in SDX driver development).

All my cards still cause the driver to report "No HDD", other than a 1GB Sandisk Ultra II which gets right through the boot process and its partitions are mounted normally. However, FDISK's interrogation of the device (rapid binary-chop sector reads to determine disk size, which is then compared with the value in the partition table to check integrity) fails with either "Read error", or the table is deemed corrupt because of a premature read-failure. So the net result is that I can't edit an existing partition table.

So - I can partition the card and reboot; however, the interface is still clearly experiencing instability. I'll try it on another couple of machines.

I haven't added any caps yet. Some photos of these in place would help greatly.

EDIT: Just tested it in a 600XL and the same card combo prevented the machine from booting at all.

Fairly disappointing so far. :(



_________________
The Last Word, MA65 Assembler, RIF SpartaDOS Utilities, XEDIT
Offline
 Profile  
 
Display posts from previous:  Sort by  
 Page 2 of 6 [ 86 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron